Bantuan » Komunitas WordPress Indonesia » Komunitas Pengguna » Kasus Aneh di Blog WP Saya

  • Saya kebetulan ada beli aplikasi dan template WP, yang kalau saya jalankan di komputer lokal saya (saya jalankan pakai http://localhost…) berjalan dan berfungsi dengan baik. Tetapi ketika saya pindahkan di hosting jadi error (tapi sebenarnya prosesnya berjalan dengan baik). Kalau saya lihat masalahnya di alamat address browser.

    Berikut ini masalahnya:

    script di file PHPnya seperti berikut :
    activate

    Kalau di komputer lokal saya ketika di klik link “activate” pada address browsernya sudah betul dengan bentuk : http://www.toserbaonline.com/controlads/zone_4

    Tapi kalau yang saya jalankan di hosting, ketika link “activate” itu saya klik, yang muncul di address browser jadinya: http://www.websiteku.com/controlads/%20//www.websiteku.com/controlads/zone_4

    Ini yang menyebabkan munculnya halaman error setelah link “activate” tersebut di klik (yang di hosting), tetapi proses (fungsi) yang dijalankan setelah link “activate” itu di klik berjalan dengan baik.

    Ada yang bisa bantu pecahkan nih ?

    PS: baik di wp yang di komputer lokal dan yang di hosting “Permalinks”-nya saya set ke /%category%/%postname%.html

Melihat 11 balasan - 1 sampai 11 (dari total 11)
  • Pencetus Utas acepsdr

    (@acepsdr)

    aduh salah, berikut ini yang ingin saya koreksi:

    activate
    harusnya “activate

    http://www.toserbaonline.com/controlads/zone_4
    harusnya: http://localhost/onlinestore/controlads/zone_4

    Pencetus Utas acepsdr

    (@acepsdr)

    Aduh gimana cara nulis yang activate-nya ya 🙂
    coba ini:

    activate

    Pencetus Utas acepsdr

    (@acepsdr)

    Coba yang ini:
    <a href="'.get_bloginfo('url').'/controlads/up_'.$postid.'">activate</a>

    Pencetus Utas acepsdr

    (@acepsdr)

    Sory, gue beberapa kali salah nulis diatas. Berikut ini saya ulangi ya:

    Saya kebetulan ada beli aplikasi dan template WP, yang kalau saya jalankan di komputer lokal saya (saya jalankan pakai http://localhost...) berjalan dan berfungsi dengan baik. Tetapi ketika saya pindahkan di hosting jadi error (tapi sebenarnya prosesnya berjalan dengan baik). Kalau saya lihat masalahnya di alamat address browser.

    Berikut ini masalahnya:

    script di file PHPnya seperti berikut :
    <a href="'.get_bloginfo('url').'/controlads/up_'.$postid.'">activate</a>

    Kalau di komputer lokal saya ketika di klik link “activate” pada address browsernya sudah betul dengan bentuk : http://localhost/onlinestore/controlads/zone_4

    Tapi kalau yang saya jalankan di hosting, ketika link “activate” itu saya klik, yang muncul di address browser jadinya: http://www.websiteku.com/controlads/%20//www.websiteku.com/controlads/zone_4

    Ini yang menyebabkan munculnya halaman error setelah link “activate” tersebut di klik (yang di hosting), tetapi proses (fungsi) yang dijalankan setelah link “activate” itu di klik berjalan dengan baik.

    Ada yang bisa bantu pecahkan nih ?

    PS: baik di wp yang di komputer lokal dan yang di hosting “Permalinks”-nya saya set ke /%category%/%postname%.html

    Pencetus Utas acepsdr

    (@acepsdr)

    Waduh, maksud anda apa ya. saya kebetulan installnya di hosting berbayar dan tidak ada masalah dalam hal install dan settingnya.

    kalau di echo $postid, hasilnya gimana mas ?

    <?php
    echo $postid;
    ?>

    Taruh di deket link activate tadi, boleh diatas atau dibawah..

    Pencetus Utas acepsdr

    (@acepsdr)

    Saya sudah coba lihat isi $postid nya dan isinya adalah angka (ID Post).

    wah nyerah.. ga ada source lengkap mas ? 😀
    selain sama $postid, saya juga penasaran dengan up_ . Terjemahannya kok bisa jadi zone ya ? 😕

    udah coba seting file “.htaccess” di root folder domain anda? biasanya kalo hostingannya di OS yang keluarga UNIX perlu nyeting .htaccess di folder rootnya ! kalo ngubah URL default ke URL “semau kita” coba cari tau gimana nambain kode di file “.httaccess” untuk aplikasi yang anda instal, saya pernah ngalami ketika ngubah URL default halaman wp saya menjadi “/%postname%.html” tapi setelah ngubah “.htaccess” jadi bisa…moga berguna n sory kalo sekiranya salah tulis or salah tangkap dengan permasalahan anda

    Tapi kalau yang saya jalankan di hosting, ketika link “activate” itu saya klik, yang muncul di address browser jadinya: http://www.websiteku.com/controlads/%20//www.websiteku.com/controlads/zone_4

    menurutku itu karena linknya ga pake http://, WordPress biasanya emang sering error gitu kalo kita bikin link di postingan kita tanpa http://

    jadi coba ubah linknya, tebakanku link aslinya pasti kayak gini:
    http://www.websiteku.com/controlads/zone_4

    coba ganti jadi kayak gini:
    http://www.websiteku.com/controlads/zone_4

Melihat 11 balasan - 1 sampai 11 (dari total 11)
  • Topik ‘Kasus Aneh di Blog WP Saya’ tertutup untuk balasan baru.