Persyaratan

Untuk menjalankan WordPress, kami sarankan dukungan host Anda:

  • Versi PHP 7.4 atau lebih tinggi.
  • Versi MySQL 5.7 atau lebih tinggi ATAU versi MariaDB 10.2 atau lebih tinggi.
  • Dukungan HTTPS

Itu saja. Kami merekomendasikan memakai server Apache atau Nginx karena keduanya solid dan mempunyai berbagai fitur untuk menjalankan WordPress, tetapi server apa saja yang mendukung PHP dan MySQL dapat dipakai. Jadi, kami tidak dapat menguji setiap environment yang ada dan semua host di halaman host kami mendukung prasyarat di atas.

Untuk rekomendasi ekstensi PHP terperinci, lihat Buku Panduan Hosting .

Catatan: Jika Anda menjalankan environment warisan (legacy) dengan versi PHP atau MySQL lama, WordPress juga dapat bekerja dengan PHP 5.6.20+ dan MySQL 5.0+, tetapi versi tersebut telah mencapai End Of Life dan dapat membuat situs Anda rentan terhadap ancaman keamanan.

Meminta segera

Berikut adalah surat yang dapat Anda kirimkan ke penyedia hosting, salin dan gunakan!

Saya tertarik menjalankan software open-source WordPress <https://id.wordpress.org/> dan saya ingin tahu apakah akun saya mendukung:

  • PHP 7.4 atau lebih tinggi
  • MySQL 5.7 atau lebih tinggi ATAU MariaDB 10.2 atau lebih tinggi
  • Nginx atau Apache dengan modul mod_rewrite
  • Mendukung HTTPS

Terima kasih!

Tidak diperlukan, tetapi disarankan untuk keamanan yang lebih baik

Hosting akan lebih aman jika aplikasi PHP seperti WordPress dijalankan menggunakan nama pengguna akun Anda, daripada nama pengguna akun server standar yang dibagikan. Tanyakan kepada hosting Anda langkah-langkah yang dapat diambil untuk memastikan keamanan akun Anda.